phpmyadmin не имеет вкладки «пользователи»

17

Я только что закончил установку phpmyadmin. Однако, похоже, что вкладка «пользователи» или «привилегии» на главной панели навигации отсутствует. Поэтому я не могу добавить новых пользователей в свою базу данных. Любая идея, с чего начать искать?

    
задан Patrick 22.09.2012 в 06:57
источник

10 ответов

17

Ответ заключается в том, чтобы перейти на 127.0.0.1/phpmyadmin вместо localhost/phpmyadmin . Он работает!

    
ответ дан Nicky Smits 17.03.2014 в 11:51
источник
11

Есть эта ошибка в phpmyadmin (или функция? кто знает больше), которая возникает, если вы вошли в систему как пользователь без разрешений. Решение заключается в очистке файлов cookie вашего браузера. Для достижения наилучших результатов перезапустите сервер mySQL, пока вы на нем.

Я использую пакет XAMPP с Apache и mySQL в Windows 7, и это сработало для меня.

    
ответ дан John 18.02.2013 в 21:23
источник
9

Он находится на вкладке Privileges

Здесь вы можете добавить новых пользователей

    
ответ дан Majid Laissi 22.09.2012 в 07:00
источник
2

в вкладке «Привилегии» нажмите «Добавить нового пользователя»

    
ответ дан Afshin 22.09.2012 в 07:09
источник
1

По-видимому, это происходит только тогда, когда вы localhost . Поэтому убедитесь, что вы обращаетесь к нему через это имя хоста, а не какой-либо другой виртуальный именованный сервер. У меня была такая же проблема, потому что я обращался к ней с помощью local , которую я установил как псевдоним для localhost .

    
ответ дан Achshar 02.02.2013 в 19:20
источник
1

Я просто хочу поделиться тем, что узнал

Первоначально у меня есть вкладка пользователей в phpmyadmin, теперь я могу получить доступ к ней через http://127.0.0.1/phpmyadmin

  • Вот первое, что, по-моему, заставило меня потерять вкладку «пользователи».

, но затем я вдруг изменил свой файл хоста (в Windows «Windows \ System32 \ drivers \ etc \ hosts»)

говорится

127.0.0.1 somehostname
#127.0.0.1       localhost
  • Еще одна вещь, но я сомневаюсь, что ее связанный

, то я изменил конфигурацию apache httpd.conf, чтобы открыть мой wamp в сети, а не только localhost

<Directory "D:/Program Files (x86)/wamp/www/">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks
    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride All
    #
    # Controls who can get stuff from this server.
    #
    # Online --> Require all granted

    #   onlineoffline tag - don't remove

    Require local
    allow from all
</Directory>
  • Я вернул файл hosts и получил доступ к phpmyadmin, используя localhost, который равен 127.0.0.1 и voila!
ответ дан bherto39 01.03.2013 в 08:06
источник
0

У меня была такая же проблема. Я использовал имя пользователя, которое мне было предложено создать при установке. Я использую Crunchbang, дистрибутив Debian, поэтому я установил через командную строку, используя apt-get. Когда я вошел в систему, поле User: показывалось как имя пользователя @ localhost. Я вышел из системы и зашел в систему, но на этот раз я ввел root как имя пользователя и использовал тот же пароль, что и моя учетная запись, и мне был предоставлен доступ.

    
ответ дан Liam89 01.03.2014 в 19:02
источник
0

У меня была такая же проблема не на localhost, а на учетной записи bluehost. По какой-то причине phpMyAdmin не имеет корневого доступа, поэтому не имеет вкладки привилегий. Вы можете добавить пользователя с использованием баз данных MySQL вместо phpMyAdmin

    
ответ дан Sydney 11.04.2016 в 20:01
источник
0

Если вы используете WHM / cPanel, эта вкладка была недавно удалена.

Смотрите: Ссылка

    
ответ дан Mike Richardson 02.03.2017 в 21:57
источник
0

Выполните следующие действия и попробуйте войти в систему как пользователь root и новый пароль.

To change the mysql password for the root user, do the following:
  
  1. выгрузить mysqld.nlm
  2.   
  3. на консоли введите: mysqld_safe --skip-grant-tables --autoclose
  4.   
  5. на консоли консоли типа mysql
  6.   

Это приведет к приглашению mysql. В этом приглашении введите следующее: (где ******** - новый пароль, ПРИМЕЧАНИЕ: одиночные кавычки НЕОБХОДИМО)

mysql> UPDATE mysql.user SET Password=PASSWORD('********') WHERE User='root';
mysql> FLUSH PRIVILEGES;

Приоритеты Flush немедленно вступят в силу.

В MySQL версии 3.22 и выше вы можете использовать инструкцию SET PASSWORD: (где ******** - новый пароль, ПРИМЕЧАНИЕ: одиночные кавычки НЕОБХОДИМО)

shell> mysql -u root mysql
mysql> SET PASSWORD FOR root=PASSWORD('********');

Другой способ установить пароль - с помощью команды mysqladmin: (где ******** - новый пароль)

shell> mysqladmin -u root password ********
shell> mysqladmin flush-privileges
    
ответ дан Arvind GK 21.07.2017 в 17:32
источник