Пакет com.google.android.maps не существует (IntelliJ)

17

Я использовал API Карт много раз раньше и не имел этой проблемы, но я явно сделал что-то не так с этим проектом IntelliJ. В разделе «Настройки» и «SDK» я определил платформу 7 API Google в пути к классам - он все еще не работает, заявив, что API карт не существует. Я также попытался добавить отдельную ссылку на путь к API API .jar, но все равно та же проблема.

Как исправить мой проект IDE IntelliJ, чтобы он правильно строился против API Google?

Прошел долгий день, я, вероятно, пропустил что-то очевидное.

    
задан Ollie C 08.06.2011 в 21:20
источник

3 ответа

37

Итак, чтобы API-интерфейсы Google (Maps и т. д.) работали в IntelliJ:

  1. В разделе File- & gt; Project Structure- & gt; SDK добавьте элемент для уровня платформы, на который вы нацелены. На вкладке classpath добавьте ссылку на верхнюю часть папки SDK android и используйте меню «Создать цель», чтобы указать, к какой платформе нужно настроить.
  2. В разделе Настройки- & gt; Структура проекта- & gt; Модули & gt; Зависимости выбирают версию SDK из списка «Модуль SDK»
  3. Если вам нужно настроить таргетинг на API Google (Карты и т. д.), то в разделе «Настройки» и «Структура проекта» и «SDKs-> gtpath» убедитесь, что вы также добавили ссылку .jar-файла для API Google для этой версии платформы (например, addons / addon_google_apis_google_inc_8 / libs / maps.jar
ответ дан Ollie C 08.06.2011 в 21:32
источник
2

В моей версии Idea элементы управления немного отличаются:

Настройки проекта - Модули - (ModuleName) - треугольник для разворачивания дерева - Android; и справа вы видите «Android-платформа:» и элемент управления выбором. В этом элементе нет «Android 2.1-update1 API Google», но вы нажимаете кнопку «Создать» и ... выбираете существующий каталог с загруженным материалом, например. / Android-SDK-mac_x86 / платформы / Android-9

Я до сих пор не понимаю, почему он читает «Новый», но он работает.

    
ответ дан 18446744073709551615 22.06.2011 в 18:41
источник
1

Я использую самую новую версию 0.8.9, и я должен сказать, что нет параметра «Параметры файла» и «Параметры», и предпочтения, достигнутые щелчком по значку инструмента, не имеют раздела «Модули» внутри. Как исправить мои проблемы с импортом com.google.android.gcm.GCMRegistrar; не найден?

    
ответ дан Fabrizio Bartolomucci 14.09.2014 в 20:00
источник