python Установка GDAL 2.1 на Ubuntu 16.04

26

Здесь будет моя последовательность командных строк при попытке установить gdal2.1 в виртуальную машину UBUNTU. Моя виртуальная машина - UBUNTU 16.04 LTS (64-битная) Мне понадобится gdal2.1 и особенно привязки Python для работы с ней в python. В настоящее время версия python установлена ​​2.7.11+, и я установил numpy, поскольку я знаю, что это необходимо для GDAL. теперь командные строки с

Инструкции, которые я нашел на странице Pypi GDAL2.1:

   [email protected]:~$ sudo apt-get install libgdal1i

   libgdal1i is already the newest version (1.11.3+dfsg-3build2).

   [email protected]:~$ sudo apt-get install libgdal1-dev

   libgdal1-dev is already the newest version (1.11.3+dfsg-3build2).

   [email protected]:~$ sudo pip install gdal

   Collecting gdal Downloading GDAL-2.1.0.tar.gz (619kB) 100%   |████████████████████████████████| 624kB 247kB/s

   Installing collected packages: gdal

  Running setup.py install for gdal ... error


  Complete output from command /usr/bin/python -u -c "import setuptools, 


tokenize;file='/tmp/pip-build-_sHDUY/gdal/setup.py';


exec(compile(getattr(tokenize, 'open', open)(file).read().replace('\r\n',


'\n'), file, 'exec'))" install --record /tmp/pip-eOB65J-record/install-


record.txt --single-version-externally-managed --compile:


running install

running build

running build_py

creating build

creating build/lib.linux-x86_64-2.7

copying gdal.py -> build/lib.linux-x86_64-2.7

copying ogr.py -> build/lib.linux-x86_64-2.7

copying osr.py -> build/lib.linux-x86_64-2.7

copying gdalconst.py -> build/lib.linux-x86_64-2.7

copying gdalnumeric.py -> build/lib.linux-x86_64-2.7

creating build/lib.linux-x86_64-2.7/osgeo

copying osgeo/gdal.py -> build/lib.linux-x86_64-2.7/osgeo

copying osgeo/gdalconst.py -> build/lib.linux-x86_64-2.7/osgeo

copying osgeo/osr.py -> build/lib.linux-x86_64-2.7/osgeo

copying osgeo/__init__.py -> build/lib.linux-x86_64-2.7/osgeo

copying osgeo/ogr.py -> build/lib.linux-x86_64-2.7/osgeo

copying osgeo/gdal_array.py -> build/lib.linux-x86_64-2.7/osgeo

copying osgeo/gnm.py -> build/lib.linux-x86_64-2.7/osgeo

copying osgeo/gdalnumeric.py -> build/lib.linux-x86_64-2.7/osgeo

running build_ext

building 'osgeo._gdal' extension

creating build/temp.linux-x86_64-2.7

creating build/temp.linux-x86_64-2.7/extensions

x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I../../port -I../../gcore -I../../alg -I../../ogr/ -I../../ogr/ogrsf_frmts -I../../gnm -I../../apps -I/usr/include/python2.7 -I/usr/local/lib/python2.7/dist-packages/numpy/core/include -I/usr/include -c extensions/gdal_wrap.cpp -o build/temp.linux-x86_64-2.7/extensions/gdal_wrap.o
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++
extensions/gdal_wrap.cpp:3085:22: fatal error: cpl_port.h: File o directory non 

esistente

compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

----------------------------------------

Command "/usr/bin/python -u -c "import setuptools, tokenize;file='/tmp/pip-build-_sHDUY/gdal/setup.py';exec(compile(getattr(tokenize, 'open', open)(file).read().replace('\r\n', '\n'), file, 'exec'))" install --record /tmp/pip-eOB65J-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-_sHDUY/gdal/

Это то, что я получил. Учтите, что у VM нет другого программного обеспечения или пакетов. Надеюсь, вы можете мне помочь, использование GDAL2.1 было бы так важно.

Я попытался попросить какое-нибудь предложение в разделе ГИС, но у меня пока не было ответов

    
задан Antonio 18.05.2016 в 10:27
источник

3 ответа

47

Что для меня работало: Ссылка

Ниже я копирую этот ответ:

Вы можете загрузить GDAL 2.1 для Windows из внутренних интерфейсов ГИС . Существует установщик и переносная версия, которая не требует установки.

GDAL 2.1 доступен для Ubuntu 16.04 из UbuntuGIS-стабильный PPA

sudo add-apt-repository -y ppa:ubuntugis/ppa
sudo apt update 
sudo apt upgrade # if you already have gdal 1.11 installed 
sudo apt install gdal-bin python-gdal python3-gdal # if you don't have gdal 1.11 already installed 

Примечание. Ubuntu 16.04 поставляется с python 3.5, но использует python 2.7 по умолчанию

    
ответ дан Akhorus 12.01.2017 в 13:38
источник
  • Работает также для Ubuntu 14.04. –  mrgloom 05.05.2017 в 11:48
  • Он работал для меня для изображения докеры Ubuntu17.10. –  Duccio A 21.12.2017 в 16:58
  • Забавно, что исходный gis-ответ имеет 12 голосов и скопированный ответ 33. –  John Powell aka Barça 19.01.2018 в 10:51
  • На самом деле неудивительно: сообщество gis.stackexchange.com намного меньше по сравнению с stackoverflow. Кроме того, умеренность там настолько тяжелая, что делает сотрудничество слишком сложным. –  Akhorus 22.01.2018 в 14:40
  • GDAL 2.1 теперь доступен в ubuntugis-stable, поэтому я могу изменить первую строку sudo add-apt-repository ppa: ubuntugis / ppa –  bsm 14.03.2018 в 03:32
10

«python-gdal» версии 2.1.0 требуется версия gdal 2.1.0. Таким образом, установка « libgdal1 » версии 1.11.3 недостаточна. Получить gdal-2.1.0: Ссылка

И зависимостей ~ 43: $ sudo apt-get build-dep gdal

Построение и установка gdal-2.1.0 и привязок Python:

$ cd gdal-2.1.0/
$ ./configure --prefix=/usr/
$ make
$ sudo make install
$ cd swig/python/
$ sudo python setup.py install

... Здесь нет проблем, используя Ubuntu 16.04 - 64 бит.

ответ дан Knud Larsen 19.05.2016 в 08:00
источник
  • Как ни странно, я получаю сообщение об ошибке - gdal-2.1.0 / .libs / libgdal.so: undefined ссылка на 'kmldom :: SerializePretty (boost :: intrusive_ptr <kmldom :: Element> const &)' - обратите внимание на обратную kmldom, но с одной кавычкой после const &). Раньше у меня было две ошибки, потому что для libgdal.so нужен png_set_longjmp_fn (), для которого требуется libpng 1.4+ - базовая установка оказалась libpng1.2.54, а когда я установил libpng16-dev, вторая ошибка сделана. –  GT. 23.07.2016 в 05:50
1

Установили python-dev ?

Прежде чем вы установите что-либо из исходного кода в Ubuntu, я предлагаю вам позаботиться о зависимостях сборки.

sudo apt-get build-dep python-gdal

Затем попробуйте запустить установку.     

ответ дан Oz123 18.05.2016 в 13:00
источник